Teamviewer large cursor on external monitor

(Hudson) #1

I was trying to connect my Laptop to my external monitor on my PC for some screen sharing purposes. But, after connecting, on the external monitor, the mouse cursor is extremely large even to a level where I cannot use the monitor at all. Is there any way to fix this?

Note: I am using Windows 10

(Muhammed Swalih) #2

It might be due to the DPI/Resolution differences between your computer and the external monitor. It is a common problem faced by several Teamviewer users. To fix it, you can try the below fix.

  1. Right-click on the Teamviewer shortcut.
  2. Select Properties.
  3. Navigate to the Compatibility tab.
  4. Click on the Change high DPI settings button.
  5. Now, click on the checkbox next to the High DPI Scaling Override and choose Application or System appropriately as per your requirements.
  6. Click OK.
  7. Reopen Teamviewer.