Teamviewer can't Connect Reason Unknown


(Shelba Ulman) #1

For the past few days, experiencing an error in the Teamviewer. When tried to connect, it outputs an error saying,
Unable to connect, Reason unknown
Do anyone know how to fix this issue? I was recently facing another issue in Teamviewer and @LakshmiPrasanna solved it. Please help me ASAP.


(Lakshmi Prasanna) #2

This can happen due to several reasons,

  1. You and your partner running different versions of Teamviewer.
  2. You or your partner didn’t restart the Teamviewer after several connections.
  3. Some programs conflicting the applications internet access (likely to be Antivirus).
  4. Your internet connection is not reliable enough to establish the connection

To fix this problem, you can

  1. Update Teamviewer to the latest version on both the ends.
  2. Restart the Teamviewer on both the ends (maybe restart the service as well).
  3. Try disabling your antivirus software.
  4. Check the internet connection speed and solve if there is any problems in the connectivity.
  5. Go for a Teamviewer alternative (there are plenty of remote control software available on the marker.)

(Shelba Ulman) #3

Thanks for your quick and fast support. The 1st one was the issue. I was running the latest beta version of the Teamviewer while he was using an old one. Told him to update the software and restarted both our Teamviewers and it is now working fine. :slight_smile:


(Wallace) #4

I have a similar issue, but none of the above worked for me. Updated the software, restarted the program and even tried restarting the PC. But still no luck. @LakshmiPrasanna can you tell me if there is anything else I can try?


(Lakshmi Prasanna) #5

Well, these are the most common fix to the problem. Did you try reinstalling the program at both sides? Or disabling the antivirus or any other remote connect applications installed?


(Wallace) #6

Thanks for the help. Tried reinstalling the Teamviewer on my PC and it worked. :blush: